Instalar impresora y escáner HP en Arch Linux

Logo HPPara hacer funcionar nuestra impresora HP en Arch Linux necesitamos instalar una serie de módulos y drivers. Con la utilidad hplip de HP tenemos un completo panel de control para configurar nuestra impresora, mirar los niveles de tinta… etc.

Comencemos:

Instalar impresora HP

1. Instalamos la plataforma de impresión cups y sus filtros:

sudo pacman -S cups ghostscript foomatic-db-engine foomatic-filters

2. Instalamos los drivers hplip:

sudo pacman -S hplip

3. Una vez instalados los componentes, iniciamos el proceso cups:

sudo /etc/rc.d/cups start

4. Iniciamos hplip-toolbox para configurar nuestra impresora:

hp-toolbox

5. Por último, añadimos cups a la sección DAEMONS en el archivo rc.conf:

sudo nano /etc/rc.conf

-> DAEMONS=(………….cups)

Instalar escáner HP

Si tu impresora es multifunción o tienes un escáner aparte, haz lo siguiente:

1. Instalamos sane (soporte para escáner) y xsane (interfaz gráfica):

sudo pacman -S sane xsane

2. Añadimos nuestro usuario al grupo scanner:

sudo gpasswd -a usuario scanner

3. Ejecutamos hp-toolbox:

hp-toolbox

Una vez iniciado hp-toolbox, seleccionamos Scan y el programa lanzará xsane para comenzar a escanear.

Eso es todo. De esta forma podremos utilizar impresora y escáner HP en Arch Linux.

Links:

CUPS – Web oficial

Common Unix Printing System – Wikipedia

25 pensamientos en “Instalar impresora y escáner HP en Arch Linux

  1. jose

    amigo alejandro de verdad necesito tu ayuda como hago para instalar una impresora a la canaimita escolar.. espero tu respuesta

    Responder
  2. karla namie

    hola yo tengo linux mint 9 y tengo poco con ella y pues ya hice todos esos pasos y pues me jala la hoja pero sale en blanco si tiene tinta lo k me di cuenta es k me dice k el filtro foormatip rip es el del problema. lo k sigue es un diagnostico de la falla. k el mismo hplip te da.ya no se k mas hacer. se les agradeceria su ayuda o los repositorios corrrectos.

    network-build=yes
    pp-build=yes
    gui-build=yes
    scanner-build=yes
    fax-build=yes
    dbus-build=yes
    cups11-build=no
    doc-build=yes
    shadow-build=no
    hpijs-install=yes
    foomatic-drv-install=no
    foomatic-ppd-install=yes
    foomatic-rip-hplip-install=no
    hpcups-install=no
    cups-drv-install=no
    cups-ppd-install=no
    internal-tag=3.11.10
    restricted-build=no
    ui-toolkit=qt4
    qt3=no
    qt4=yes
    policy-kit=no
    hpijs-only-build=no
    lite-build=no
    udev-acl-rules=no
    hpcups-only-build=no
    hpijs-onl8y-build=no
    (foomatic-rip-hplip-install=no)

    Responder
  3. Jorge

    Ayuda!!!!! Por favor!!!! Tengo Ubuntu 11.10 instalado y necesito instalar un Plotter HP DesingJet T1100 44in, tengo los drivers de wins y mac pero no para linux u ubuntu.
    Trate de encontrar algo en cups, pero no hay nada!!! Trato de instalarlo via wine y nada!!!
    no se que puedo hacer!!! alguna idea!!! o sera posible convertir los drivers de wins para linux?
    Puede ser red o usb, con del hplip no funciona o no lo detecta!!!
    que se puede hacer?…….=( °°(

    Responder
    1. alejandrocq Autor de la entrada

      Asegúrate de haber hecho los pasos correctamente. De todas formas, existe la utilidad Ndiswrapper, con la que se pueden usar algunos drivers de windows en linux, pero no se si soporta drivers de impresoras, normalmente suele usarse para placas wifi.

      No lo he usado nunca, así que no puedo ayudarte mucho, pero puedes buscar algún tutorial para utilizar ndiswrapper.

      Un saludo y suerte !

      Responder
    1. alejandrocq Autor de la entrada

      Ejecuta hp-toolbox como usuario normal. Si lo ejecutas como root, el programa no puede crear una ventana en el servidor gráfico ya que el usuario normal es el que ha iniciado sesión gráficamente.

      Un saludo !

      Responder
      1. Courage

        Tengo que recurrir otra vez en tu ayuda

        Al ejecutar hp-toolbox en modo usuario me sale esto

        error: Unable to load Qt4 support. Is it installed?

        ¿Qué paquete tengo que instalar?

        Gracias

  4. algoban

    Hola

    Respecto a este tutorial, una consulta.

    ¿Es posible utilizar xsane sin tener que llamar hp-toolbox?. Lo digo porque es bastante tedioso.

    ¿ He de añadir algo al arranque o modificar algo?

    Muchas gracias

    Responder
    1. alejandrocq Autor de la entrada

      Hola !

      Pues la verdad no he logrado que xsane reconozca mi impresora. Solo lo hace cuando lo uso desde hp-toolbox, por eso he puesto este modo.

      Saludos !

      Responder
  5. Jose Luis

    Olvide decir que en Sinaptec busque gcc y aparece configurado correctamente. Por lo que no comprendo lo de “error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.”. Indico esto por si existia la duda con respecto a si estaba gcc instalado o no en el equipo.

    Reitero el saludo y ojala tengais respuestas.

    Responder
    1. alejandrocq Autor de la entrada

      Hola Jose Luis !

      Veo que no te has fijado muy bien el título. El tutorial es para la distribución Arch Linux, no para Debian. Supongo que con apt podrás instalar los paquetes que necesitas y sus dependencias. Prueba:

      sudo apt-get install gcc

      O busca en los repos de debian a ver si está disponible alguna versión de hplip.

      Saludos !

      Responder
      1. Jose Luis

        Gracias por responder tan pronto, perdon no se en que se diferencian las arquitecturas de Arch y Debian por lo que supuse desde mi ignorancia que quizas pudierais ayudarme pues a veces soluciones de Ubuntu son validas tambien para Debian, pero por lo que parezco intuir en tu respuesta y desde mi ignorancia parece que entre Arch y Debian no sucede lo mismo.

        Con respuesto a tu consejo , obtuve esta respuesta;

        sudo apt-get install gcc
        Leyendo lista de paquetes… Hecho
        Creando árbol de dependencias
        Leyendo la información de estado… Hecho
        gcc ya está en su versión más reciente.
        0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.

        Por lo que por desgracia aun sigo con el problema.

        Un Saludo.

      2. alejandrocq Autor de la entrada

        Sí, me lo imaginaba. Gcc es un compilador de aplicaciones y suele venir en todas las distribuciones por defecto. Solo te queda probar esto:

        sudo apt-cache show hp

        De esta forma buscará paquetes relacionados con hp. Quizá hplip esté en los repositorios de debian y puedas instalarlo así.

        Saludos !

  6. Jose Luis

    Tras ver vuestro explicacion he intentado configurar el HP Officejet G85 y no logro que funcione el escaner, la impresora va bien pero con el escaner estoy al borde de la desesperacion, pues si no logro instalarlo tendre que volver al indeseado windows, por temas de estudio.
    En el punto 1 de tu articulo me responde; “sudo: pacman: command not found” no se si es porque estoy en Debian 5.0. con Gnome, o por otra causa y en el punto 3 me indica; Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.

    warning: hp-toolbox should not be run as root.
    error: PyQt not installed. GUI not available. Exiting.
    warning: Qt/PyQt initialization failed.
    error: hp-toolbox requires GUI support. Exiting.

    Tambien he intentado instalar HPLIP 3.10.6 desde esta web:
    http://hplipopensource.com/hplip-web/install/install/index.html

    y al final me indica lo siguiente;

    INSTALL MISSING REQUIRED DEPENDENCIES
    ————————————-
    warning: There are 8 missing REQUIRED dependencies.
    note: Installation of dependencies requires an active internet connection.
    warning: Missing REQUIRED dependency: gcc (gcc – GNU Project C and C++ Compiler)
    warning: This installer cannot install ‘gcc’ for your distro/OS and/or version.
    error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

    Espero vuestra ayuda, un saludo.

    Responder
  7. Pingback: Articulo Indexado en la Blogosfera de Sysmaya

  8. Walter Morales

    Alejandro,

    Quería hacerte una pregunta, Estoy con ganas de instalar Arch por el hecho de que la instalas y te olvidas de actualizar la distribución, pero como yo uso la compu como herramienta de trabajo, me hace pensar eso de que para todo hay que usar la consola porque no quiero perder demasiado tiempo buscando y buscando… piensa que con Ubuntu yo salto de LTS a LTS. ¿No se pueden instalar paquetes de manera gráfica?

    Saludos,

    Walter

    Responder
    1. alejandrocq Autor de la entrada

      Hola walter😉

      Lo principal es instalar el entorno de escritorio y los controladores de la gráfica para tener entorno gráfico y a partir de ahí hacer los cambios.

      Hay distribuciones basadas en Arch Linux (creo que hay una con GNOME por defecto), pero no estoy seguro de si tienen instalador gráfico o es sencillo.

      De todas formas, ten en cuenta que los repositorios de Arch son muy completos y con las aplicaciones más comunes. Incluso cuentas con yaourt para instalar aplicaciones que no esten en los repos y se bajen desde AUR.

      Te recomiendo la página oficial de arch, en la que puedes buscar los paquetes que necesites de los repositorios, para saber el nombre e instalarlos con pacman. Luego instalas todo de golpe y tendrás entorno gráfico con las aplicaciones que necesites.

      Una vez instalado todo, tienes una rolling-release en la que no necesitarás pasar de versión en versión o de LTS a LTS.

      Ten en cuenta también que hay algunas aplicaciones que quizá no se actualizen aunque sean LTS o necesites repos externos.

      Te recomiendo que vayas poco a poco instalando Arch sin prisas, cuando tengas tiempo.

      Espero haberte ayudado.

      Saludos !

      Responder
      1. Walter Morales

        Muchas Gracias Alejandro. Me voy a animar a instalarla en la eeepc, y si me siento cómodo, la paso a las otras dos.

        Un abrazo

  9. Pingback: Tweets that mention Instalar impresora y escáner HP en Arch Linux « El blog de alejandrocq – Linux, Tecnología, Internet -- Topsy.com

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s